Particle Input for Binary Particle System

I try to simulate a 3D binary fluidization system, and I use Particle_Input.dat file for particle generation. But its don’t work in the right way! Each phase that I define at the beginning, all the particles in the system are created with the characteristics of that phase. Look at the below pictures:

In addition, large particles are formed larger than they defined.
However, this does not happen in the 2D simulation:

I attach the .mfix file and Particle_Input.dat file below:
3D-Binary.mfx (13.1 KB)
particle_input.txt (121 Bytes)

Thanks for your bits of help.

You need to save the particle diameter to the VTP file by enabling the checkbox for “Diameter” under Output > VTK > Select Particle Data to Write.

Alternatively, you can manually set vtk_part_diameter(1) = True.

@subhodeep88 is probably correct. If you don’t save the particle diameter in the VTK files (*.vtp), then the GUI will automatically grab the diameter of the first solid to scale the the particles.

@onlyjus I tested it with the particle diameter saved and it resolves the issue.

Thanks for your valuable guidance.
It worked properly.