Can not build custom solver on the examples that comes with Mfix-23.2: silane_pyrolysis_tfm_2d in Windows 11

Intel I5 1135G7, 8GB ram DDR4, Windows 11 64 bits - Anaconda Lastest Version - MFIX 23.2. I have tried in another 2 computers with Windows 10 64 btis, same version of Anaconda and MFIX 23.2.
I attach the result proyect if it helps: “”

I have generated the mesh. After that, went to “build solver” because i need gfortran as the default solver.
When i click on “build solver” i get the following error:

Running python -m mfixgui.build_mfixsolver -DCMAKE_Fortran_COMPILER=gfortran
Building custom solver for silane_pyrolysis_tfm_2d.mfx
Running cmake command:
cmake -DCMAKE_Fortran_COMPILER=gfortran -DENABLE_PYMFIX=ON -G “MinGW Makefiles” -DCMAKE_INSTALL_PREFIX=C:\Users\Lucas\Desktop\MFIXSimulaciones\silane_pyrolysis_tfm_2d -DUDF_DIR=C:\Users\Lucas\Desktop\MFIXSimulaciones\silane_pyrolysis_tfm_2d -DVERSION=23.2 C:\Users\Lucas.conda\envs\mfix-23.2\share\mfix\src


It does not give me more information than that.
Thank you.

I am not able to reproduce this with mfix 23.2 on Windows11.

Can you please click “Verbose” in “Build options” and try again? This should cause the build script to show additional detail, maybe this will help us see where the problem is.

Hi, with Verbose activated it gives me:
“Version control operation failed: [Errno 22] Invalid argument”
and on the console, i see the same message:
“Version control operation failed: [Errno 22] Invalid argument”
I put in a zip, the results. (103.5 KB)

i have attached the 3d case, because with the 2d, it does not give me any extra information, and no prompt.

could you inform me about which versions are you using of anaconda and mfix please? also any other information that may be useful. Like the global varaibles, or the variables that are in the Enviromental Variables of Windows maybe.
I Have tried lot of things, but with no positive results.
Thank you in advanced

I do my testing on a Windows 11 system which is pretty standard - I don’t set any special environment variables, etc. But I have switched from Anaconda to Mambaforge, because it is a lot faster to install and I do a lot of test installations.
You can read about it here

I’m not sure if you were able to run the simulation on your Windows 11 computer (2d or 3d, it is the same for me rigth now).
I installed the latest version of Linux Mint on my computer, and it works perfectly after installing the CMAKE library. I’ll be using Linux until this problem is solved.
I’ll try installing what you suggested in the link. Thank you very much!

1 Like

These examples run for me on Windows 11, I am sorry that I am unable to determine what’s going wrong on your system, but I’m glad you found a workaround. And your simulations will probably run faster on Linux too!