Does MFiX works on M1 MacBook Pro?

Hi Developers. Does MFiX works on an M1 MacBook Pro? On my M1 Mac it doesn’t run. Can you help me?

@francescomazza - I think you might be the first one to try it.

We don’t currently have any M1 hardware for testing. We may support this platform in the future but at the current time it is not officially supported. (Same goes for Windows 11).

However, I can try to offer a bit of advice and assitance. Can you provide more details other than ‘doesn’t run’? How have you tried to install it?

– Charles

– Charles

Thank you for the answer. I followed the instructions contained in this link: Register - NETL Multiphase Flow Science. I run “conda activate mfix-21.3.2” and “mfix” commands on terminal, but it doesn’t run. This is the screenshot of the terminal window:

The python3.8 app doesn’t work, and after a lot of minutes it crashes.

The 21.3 version, installed a few months ago, worked with some problems, but there isn’t and I can’t test it again.

We rely on Anaconda for all of the dependencies required for MFiX. Anaconda does not yet support the M1 processor, according to this:

So, we will not be able to support MFiX on M1 until Anaconda is available for M1.

You may be able to build a batch-mode solver on this platform (no GUI) if you can get a working GFortran. But I think it’s safe to say that at this point Apple/M1 is an unsupported platform for MFiX.

– Charles

Thank you, @cgw! I’ve an other question for you: can you give me the 21.3 version of MFiX? That version runs on M1 Mac, but there isn’t in the download page. We can evaluate problems of a working version of MFiX. What do you think about this idea?

How did you get 21.3 MFiX running on M1 without using Anaconda?

21.3.2 is the same as 21.3 with only a few small bug fixes, so it doesn’t really make sense to me why 21.3 would work but not 21.3.2. I supect it might be some other problem.

The MFiX download page offers access to earlier versions, but when we make a bug-fix release (aka “point” release) it replaces the previous one on the list of available versions - this is why 21.3 is not listed on the download page, we prefer users to use 21.3.2 instead to avoid known bugs.

But you can still access 21.3 if you really want to - copy the download command from the “Download MFiX” page and just change 21.3.2 to 21.3 everywhere it occurs - 6 places on the command line. The install command should look like

conda create -n mfix-21.3 mfix=21.3 mfix-doc=21.3 mfix-gui=21.3 mfix-solver=21.3 mfix-src=21.3 -c conda-forge -c https://mfix.netl.doe.gov/TOKEN/conda/dist

Of course, that command won’t work unless you replace TOKEN by your own download token

– Charles

Ok, there’s not yet an Anaconda for M1 (“Apple Silicon”) but there is a Miniforge installer for this platform which might work - did you start from this?