Error on Installation of Batch Solver at Linux

Hi there,

I have a problem with batch solver MFIX 23.3.1 installation on Linux. I normally work on my computer (Windows) but I didn’t do the same things with Linux. Unfortunately, I don’t have enough Linux experience to handle this problem. I did the things that were discussed in the following topics but it didn’t work.

My problem is that;

Thanks for your help

The “bad value (haswell)” error is appearing because you are using a very old version of GFortran (4.8.5). The current version is 13.2.0.
You can disable this by editing the file $CONDA_PREFIX/share/mfix/src/model/CMakeLists.txt and change line 591 from

  	  set (MARCH "-march=haswell")


  	  set (MARCH "")

This will allow you to use your older compiler, with some loss in code execution speed.

However, you should not have to do this, because you are running MFiX 23.3.1 and we included a recent GFortran in that package. You should be running gfortran 13.2.0 from the Conda package.

Can you please activate the MFiX environment and type these commands?

bash$ mamba activate mfix-23.3.1
(mfix-23.3.1)$ which gfortran
(mfix-23.3.1)$ gfortran --version
GNU Fortran (conda-forge gcc 13.2.0-2) 13.2.0
Copyright (C) 2023 Free Software Foundation, Inc.

Also please attach the output of conda list and mfixversioninfo (or go to main menu and select “Submit bug report”)

– Charles

I recognized that my g Fortran version was too old after the submission. I fixed it similarly and it is currently solved.

Thank you for your response