Install MFIX-19.1.0 by tarball

Hi Dear MFIX Team,
I am trying to install MFIX-19.1.0 tarball (DMP version) on my PC with Linux Mint 18.0 operating system. I got this error. I think this may stem from the uninstallation of openMPI in my system. Which openMPI is suggested for MFIX? Like mpif90 or others? Thank you.


You do not have mpif90 installed as shown by the output from
mipf90 --version

It even suggests where to find the packages and how to install them.

If Linux Mint is based on Debian and Ubuntu, try apt install openmpi-bin libopenmpi-dev

HI Mark,I tried this command on my PC “sudo apt-get install openmpi-bin openmpi-doc libopenmpi-dev”. AFter the installation, I still can not find mpif90 or mpifort, illustrated in this picture. Would you like to tell me how to install mpif90? Thank you.

Hi Mark, I think I know the reason why I can not use mpif90. I did not install gfortran. When I tried this “sudo apt-get install fortran”, I got this instead:

so where could I find the source to install gfortran? Thanks.

Try sudo apt update then try sudo apt install gfortran.

It looks like you may have some network issue; keep trying until it works.

Hi Mark,
Thank you for your help. I tried “sudo apt update”, but it did not work. So I tried “sudo apt-get update”, it works! Gfortran found the source. I am so glad to tell you this.

1 Like