Install MFiX on computer cluster

I am installing MFiX on a computer cluster. The MFiX conda environment has been configured successfully, but when I am going to build the MFiX solver with the command:

build_mfixsolver -DCMAKE_BUILD_TYPE=Debug --batch --smp -j -SMP_Fortran_COMPILER=gfortran -DCMAKE_Fortarn_FLAGS="-o3 -g -fcheck=all"

I got the error: “-bash: build_mfixsolver: command not found”.
How can I solve this problem? Thanks in advance for your help.

looks like build_mfixsolver is not in your path, did you activate the conda environment?

conda activate mfix-20.2.1

Thanks Justin. You are right! Now I am able to use DMP on my cluster but the simulation interrupts once in a while. However, I have set the " chk_batchq_end = .False."
I think it is a memory leak problem.
I build my solver using the:
build_mfixsolver -DCMAKE_BUILD_TYPE=Debug --batch --dmp -j -DMPI_Fortran_COMPILER=mpifort -DCMAKE_Fortarn_FLAGS="-o3 -g -fcheck=all"
and compile it by:
mpirun -np 96 --hostfile host ./mfixsolver -f filename.mfx (host is a file that includes names of the nodes that will be used in the simulation!)

Do you think if I should change the build command?

I have this problem before, but since I was using a simple CPU on that time, I changed the DMP keyword to SMP and MPIFORT to GFORTRAN and it worked! But now on the cluster, I do not know what should I do?


What compiler version and mpi version are you using? We have seen memory leaks with very specific version combinations.

mpirun (Open MPI): 2.1.1
GNU Fortran: 7.5.0
Ubuntu version: 18.04.5

I have checked the 3D rectangular FB of the MFiX projects and I faced the memory leak again! So it could only be due to the commands or my compiler? What do you think I should do, @onlyjus?

We know that this combo on CentOS has a memory leak:

gnu/8.2.0 openmpi/3.1.3

These run fine on our system:

gnu/6.5.0 openmpi/3.1.3
gnu/8.2.0 openmpi/3.1.6
gnu/8.2.0 openmpi/4.0.1
gnu/8.4.0 openmpi/4.0.3
gnu/9.3.0 openmpi/4.0.4

Are you running one of the tutorial cases?

Actually to make sure that the problemis not because of the stl geometry, I tried the 3D rectangular FB at the GUI examples and it also gad memory leak! My simulation models drying in a frustum shape fluidized bed.
And do you think that the build and compile commands that I use are correct?

Thank you @onlyjus. I have installed one the combos and it apparently does not have the memory leak, but my simulation again interrupts once in a while! I use the nohup command to monitor the history and there is no error in it and only the iterations have stopped! The check_batchq_end is also False and the LOG file does not contain any error and the last lines are only the consecutive timesteps!

Can you post the log file and the last 10 lines of stdout?

Thanks for your prompt response? What do you mean by the stdout?
I am running it again, when it stops again, I can send you any file which is needed.

If you mean the terminal output by the stdout, then I have attached the screenshot of the last 30 lines of the nohup.out file and also the OUT and LOG filesLOG and|attachment (123.6 KB)