Issue in compiling solver with DMP support on HPC

Hi, I am trying to compile solver for a custom test case with DMP support on HPC. I am able to build solver in serial but building solver in parallel throws out this error

[ 10%] Building Fortran object model/CMakeFiles/mfixcore.dir/write_usr1.f.o
[ 10%] Building C object model/CMakeFiles/mfixcore.dir/xpow.c.o
/home/chemical/dual/mfix-23.2/model/xpow.c:1:0: error: bad value (haswell) for -march= switch
/* xpow.c - replacement pow() function that detects integer and dyadic exponents
make[2]: *** [model/CMakeFiles/mfixcore.dir/xpow.c.o] Error 1
make[2]: *** Waiting for unfinished jobs…
make[1]: *** [model/CMakeFiles/mfixcore.dir/all] Error 2
make: *** [all] Error 2

I have tried building with various gcc, mpi versions but i am unable to resolve this error.
Anyhelp would be appreciated

For reference:
$ cmake ~/mfix-23.2 -DCMAKE_Fortran_COMPILER=mpifort -DENABLE_MPI=1
– Setting build type to ‘RelWithDebInfo’ as none was specified.
– MFIX build settings summary:
– Build type = RelWithDebInfo
– CMake version = 3.23.1
– Fortran compiler = mpifort
– Fortran flags =
– The Fortran compiler identification is GNU 9.1.0
– The C compiler identification is GNU 4.8.5
– Detecting Fortran compiler ABI info
– Detecting Fortran compiler ABI info - done
– Check for working Fortran compiler: /home/soft/centOS/compilers/gcc/openmpi/4.0.2/bin/mpifort - skipped
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Check for working C compiler: /usr/bin/cc - skipped
– Detecting C compile features
– Detecting C compile features - done
– Performing Test ffpe_trap
– Performing Test ffpe_trap - Success
– Performing Test ffpe_summary
– Performing Test ffpe_summary - Success
– Found MPI_C: /home/soft/centOS/compilers/gcc/openmpi/4.0.2/lib/ (found version “3.1”)
– Found MPI_Fortran: /home/soft/centOS/compilers/gcc/openmpi/4.0.2/bin/mpifort (found version “3.1”)
– Found MPI: TRUE (found version “3.1”)
– Found Git: /usr/bin/git (found version “”)
CMake Warning at model/cmake/MfixOptions.cmake:112 (message):
Unknown CMake version
Call Stack (most recent call first):
model/CMakeLists.txt:681 (set_mfix_version)

Found UDFs:
– Configuring done
– Generating done
– Build files have been written to: /home/chemical/dual/ch7190161/case0

That is too old. You need to either use a newer compiler (suggested) or disable the -march=haswell CPU optimization flag (which will work but result in slower code).

Please see this forum posting