Launching error


I just installed mfix and tried launching it. But it showed me this error. What should I do now? Thanks for your help!

Traceback (most recent call last):
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\Scripts\”, line 9, in
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\mfixgui\”, line 3445, in main
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\mfixgui\”, line 3563, in main_args
loadvtk=args.novtk, set_splash_text=set_splash_text, style=use_style)
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\mfixgui\”, line 577, in init
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\mfixgui\”, line 1492, in init_vtk_widget
from .vtk_widgets.modeler import VtkWidget
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\mfixgui\vtk_widgets\”, line 38, in
from mfixgui.vtk_widgets.geometry_engine import GeometryEngine
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\mfixgui\vtk_widgets\”, line 39, in
from import procedural_stl
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\mfixgui\tools\”, line 7, in
import splipy as sp
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\”, line 5, in
from splipy.Curve import Curve
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\splipy\”, line 9, in
import scipy.sparse.linalg as splinalg
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\scipy\sparse\”, line 114, in
from .eigen import *
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\scipy\sparse\linalg\”, line 9, in
from .arpack import *
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\scipy\sparse\linalg\eigen\”, line 20, in
from .arpack import *
File “C:\Users\ashin\anaconda3\envs\mfix-21.1.4\lib\site-packages\scipy\sparse\linalg\eigen\arpack\”, line 42, in
from . import _arpack
ImportError: DLL load failed: The specified procedure could not be found.


Hi @Ashin_Sunny , welcome to MFiX

I haven’t seen this error before. But we are releasing a new version, 21.2, very soon. It hasn’t been announced yet, but if you do
conda deactivate
then repeat the installation command with all of the 21.1.4’s replaced by 21.2, and -c mfix replaced by -c conda-forge you will be able to do a test installation of the new version. That is, the installation command should look like

conda create -n mfix-21.2 mfix=21.2 mfix-doc=21.2 mfix-gui=21.2 mfix-solver=21.2 mfix-src=21.2 -c conda-forge -c

I’d be very interested to know if the 21.2 version also has this DLL load failed issue.

– Charles

1 Like

Hi Charles,

For now, I have installed a previous version and it is working. I will let you know if have the same error when I install the latest version in the future.