MFiX installation in Windows Subsystem for Linux (WSL)

Dear MFiX team

I tried to install MFiX in Linux (window subsystem for linux). Anaconda and MFiX were installed successfully. But I got an error like below when I run MFiX. Can you help me?

Daniel Kim

WSL don’t support gui, so you still need to install mfix gui under windows system, and use window mfix gui to create dat file. Then you can build your solver directly from source code under WSL in the same way as using the version before mfix-16.1.

To install on Ubuntu, sudo apt install libgl1.

You can run GUI programs in WSL, but you need to install Xming (or some X display server for Windows.) After installing, run Xming (Xming Server should appear in your Windows system tray).

Then run mfix in WSL with environment variable DISPLAY=:0 set.

There are a lot of VTK messages, and this is not an officially supported way of running MFiX, but it works for me. Please share your experience, if it works for you.

Actually, I reinstalled Linux separately not for the WSL. After that, it works well. Thank you!!

I tried to create the environment in Linux, but it did’t work like below.
Can you help me?


When installing Anaconda, make sure to add it to your PATH.

You may need to logout and log back in.

Then, do I need to remove and reinstall Anaconda so that the path would be correct?

Just edit your .bashrc file.
Follow this guide:"command-not-found"-error

I couldn’t find .bashrc file in the home/user/ folder . However, I thought that the anaconda3 was installed in home/user/anaconda3/ folder well.

I uninstalled anaconda and reinstalled it. For this time, I selected yes in the question of “Do you wish the installer to initialize Anaconda3 by running conda init [yes|no]”
After that, it started to appear “(base)” at the beginning of line. There was no (base) sign before. Anyway, after appearing “(base)”, the step of creating and activating the environment works well. Many thanks!