Mfix is not installing


Type of issue
Setup in GUI, meshing, solver crash, solver non-convergence, etc.

Details on how to reproduce the issue. If MFiX crashed or failed, how long does it take?

Attempts to fix the issue
Include what you have tried, what helped and what didn’t help.

Did you?

  • Select the relevant category (Installation / How to / Bug report / Share)?
  • Search the forum for similar issues, Read the documentation (MFiX User Manual — MFiX 23.2 documentation)?
  • Inspect the console, error and warning messages?
  • Modify the code, or write UDFs?
  • Run the solver in debug mode?

Attach project files
Attach zip file generated from main menu> submit bug report.
ERROR REPORT .zip (1.5 KB)

requests.exceptions.HTTPError: 404 Client Error: Not Found for url:

This is a network error and is usually transient. Can you please try again?

I tried many times but it is not installed

Error is coming
(base) C:\Users\hp>c
Collecting package metadata (current_repodata.json): failed

# ERROR REPORT1 .txt (5.6 KB)

Maybe it was about a connection error with the servers. Would you try again to install it? I am installing the latest version of MFiX right now.

1 Like


  1. Do not post the download links publicly

  2. Why are you installing version 23.1.1 instead of 23.2 which we just released?

I had also tried to install the 23.2 but the problem was the same coming.

Sorry for the mistake. I’ll be careful next time.

I really don’t understand what’s going on here.

In your error report, the key error is:

    requests.exceptions.HTTPError: 404 Client Error: Not Found for url:

The string new_channel_url in there looks suspicious, that looks like a variable that should have been replaced with an acual value.
I am not able to reproduce this - I just re-installed both 23.2 and 23.1.1 without issues.

Perhaps you can try the alternate miniforge/mamba-based setup -

Alternate install instructions

In fact, we’re planning on making this the default installation method, since it is a smaller download and quicker installation.

I tried it too but couldn’t find the solution. What is the reason behind this, is it an anaconda problem or mfix problem?