Partial slip wall for solids

I want to use Mixed wall boundary type. The Jackson-Johnson partial slip boundary is not activated. I know that I need to enable solving granular temperature equation for that. But I do not know how to turn it on???

duct-gravity-along.mfx (17.5 KB)

Any guidance for my question??? Also, by the way what is the Transfer under momentum boundary condition???

For the solid boundary, you should choose partial slip or free slip to activate the JJ boundary.

The problem is that choosing either of the partial or free slip does not activate the JJ boundary… ! Is there anything else that should be chosen ???

I have solved it because I had the same issue just yesterday.

For some reason, you can’t modify it in the GUI, but you can modify the keyword ‘BC_JJ_PS’ if you open up the .mfx file in editor. 0 to turn it off, 1 to turn it on. After turning it on, you will be able to modify specularity and restitution coefficients.

how to turn it on in the editor, as I seen that it is not editable

Controls which are disabled in the GUI are disabled because those options are not compatible with the model type selected. This is to keep the users (you) from selecting combinations of settings which do not make sense.

In this case, you may think you are setting the Jackson-Johnson boundary type, but that doesn’t mean the solver is respecting these values. Simiar for specularity and restitution - the values you are forcing in there are probably not being used.