Problems at uninstall MFiX

Excuse me, I have installed the MFiXs in my PC(Windows), of which 21.3.2 and 21.4 version both exist. Now I want to uninstall old versions and install the latest version, 22.3.
However, I found that I couldn’t uninstall the old version. When I try to uninstall both of them, my terminal window always says: “Verifying transaction: failed”, and other “CondaVertificationError” or “ClobberError”.
I have no ideas how to uninstall them. Could you please teach me the way to uninstall the old versions in my PC?
Here are pictures of my terminal window when I try to uninstall.

Hi @ZhuHe - I’m sorry you are having difficulties with Conda

I can see the errors in your screenshot but not the original command you typed.

First do conda deactivate because you cannot remove an active Conda environment

If you do conda env list you should see something like this:

base                     /home/cgw/mambaforge
mfix-22.1.1              /home/cgw/mambaforge/envs/mfix-22.1.1
mfix-22.2                /home/cgw/mambaforge/envs/mfix-22.2
mfix-22.2.1              /home/cgw/mambaforge/envs/mfix-22.2.1
mfix-22.2.2              /home/cgw/mambaforge/envs/mfix-22.2.2
mfix-22.3             *  /home/cgw/mambaforge/envs/mfix-22.3
mfix-99.9.9              /home/cgw/mambaforge/envs/mfix-99.9.9
mfix-git                 /home/cgw/mambaforge/envs/mfix-git

If any of the environments has a * next to it, it is currently active and needs to be deactivated - you cannot remove an active env. conda deactivate will fix that.

Finally, conda env remove -n mfix-22.1.1
will remove the environment with the specified name

I tried removing mfix-22.1.1 and got this warning

 RequestsDependencyWarning: urllib3 (1.26.9) or chardet (5.0.0)/charset_normalizer (2.0.12) doesn't match a supported version!

but it did not prevent the package from being removed. I confirm this by doing conda env list again.

Can you tell me a little bit more about how you installed in the first place (system-wide or personal user installation) and also the commands you used to try to delete.

If all else fails, you should be able to simply delete the entire directory:

C:> del /S /Q D:\ANACONDA\envs\mfix-22.1.1
making sure the directory name matches what’s in conda env list

Be careful doing this, you could wipe out the wrong thing if you get the command wrong.

Let me know how it goes! Thanks.

Hi, Charles @cgw . I’m so glad that you can focus on my problem.

When I installed the MFiXs, I just fellow the user manual what it guided me do. The same goes for uninstalling.

For example, When I want to uninstall my MFiX-21.3.2, I use the follow commands:
conda activate mfix-21.3.2

And then use conda uninstall mfix

But when I run command conda uninstall mfix , it always says there are some errors.

In your reply, it seems to that the command conda env remove -n mfix-21.3.2 can only remove the conda environment. I’m confused about whether it can remove the MFiX application.

That’s all. Hope to receive your reply. Thanks!

Interesting, the command reference for Conda Command reference — conda 22.9.0.post59+352bcb3f1 documentation

doesn’t even mention a conda uninstall command. Perhaps the user manual needs to be updated.

Removing the mfix environment will remove the MFiX application and all of its dependencies. This is probably the best way to remove old MFiX versions.

removing the mfix environment should have the same

Thanks. I tried the command conda env remove , and it worked. The command successfully removed my old version MFiX. Thanks again.