Problems running Tracker in Ubuntu (WSL)

Hi! I’ve install Tracker in Ubuntu (WSL) using Conda but when I try tu run it the following message appears (I’m a Ubuntu newbie).

(base) pala@LAPTOP-AT7IS4KS:~$ tracker
Traceback (most recent call last):
  File "/home/pala/anaconda2/bin/tracker", line 6, in <module>
    from import main
  File "/home/pala/anaconda2/lib/python2.7/site-packages/tracker/", line 562
    def call_back(*args, cc=clear_cache, cs=clear_synth, p=process):
SyntaxError: invalid syntax

Thanks in advance!

I have not tried running tracker in WSL. What version of python?

Hi! I’m using python 2.7.17 on conda 4.7.12

I haven’t tried tracker with 2.7. I am developing with 3.6 atm.

Can you create a conda environment with 3.6?

conda create -n tracker19.1 python=3.6

I´ve create the environment correctly but when I try to run Tracker the same error message appears.
May be I just use Tracker in Windows for now.

Ok. I don’t have a windows machine with WSL atm to debug. I’ll see if I can get my hands on one.