Tracker launching but closing instantly

Hi!
I just installed tracker through anaconda. I installed this within an environment. On launching the tracker app the GUI launches but automatically closes within a couple of seconds with this error in the anaconda prompt:

(trackerenv) C:\Users\Agastya Balantrapu>tracker
Traceback (most recent call last):
File “C:\Users\Agastya Balantrapu.conda\envs\trackerenv\lib\site-packages\tracker\app.py”, line 289, in get_cpu_ram
ui.progressBar_cpu.setValue(c)
TypeError: setValue(self, int): argument 1 has unexpected type ‘float’

I would appreciate any assistance on this!

I thought I fixed that, what version installed? 22.1?

Thanks @onlyjus. Yes this is 22.1. And this is Python 3.10 I am using through anaconda.

I figured it out, will push a new version.

Thanks, I really appreciate it Justin. Please let me know when the new version is out!

Hi @onlyjus, really sorry to bug you. Any chance you were able to push out a new version?
Thanks.

I fixed it in like 5 minutes, and having been struggling with pushing the package to the website… Darn CI pipeline.

Here is the diff if you are comfortable editing the code directly:

tracker/app.py
@@ -285,9 +291,8 @@ class TrackerGui(QtWidgets.QMainWindow, MainMenu):
 
         c = psutil.cpu_percent()
         r = psutil.virtual_memory().percent
-
-        ui.progressBar_cpu.setValue(c)
-        ui.progressBar_ram.setValue(r)
+        ui.progressBar_cpu.setValue(int(c))
+        ui.progressBar_ram.setValue(int(r))

Finally got it pushed to the conda repo. Tracker 22.1.1 should install now.

That worked! Thanks a ton for your service @onlyjus!

Actually, it did but it crashed again as soon as I loaded a .mp4 file. See below. Any thoughts?

What Qt version do you have? Seems like they changed stuff.

I have Qt 5.9.7 and Qtpy 2.0.1

I have been developing with Qt 5.12.9 without problems and I can’t reproduce with:

Python version:  3.7.12
Qt wrapper:  PyQt5
Qt version:  5.9.7
qtpy version:  2.1.0
Numpy version:  1.21.6
Scipy version:  1.7.3
OpenCV version:  3.4.2

It looks like there is an issue with your Qt version where the floats are not being converted to the ints that Qt wants. I think I know where these are and will convert them manually.

Ok I deployed 22.1.2, see if that works. Sorry you are being a tester :frowning:

That seems to work Jason. Thanks and sorry for bugging you repeatedly. I will reach out to you if I find other bugs.
Thanks

Awesome! Thanks for testing.