Unable to properly install MFiX-22.4.2 (source installation package installation)

Dear designer, I tried to use Anaconda to install MFiX-22.4.2, but I could not connect to the source data package because of network problems, so I had to use Pip to install MFiX-22.4.2. After I downloaded the source installation package (. tar file), I ran the setup.py file in the package, and then ran the startup command, but the running environment could not be activated. My existing environment is listed in the following figure, What should I do to properly start MFiX-22.4.2? Thank you very much.

Hi - I think you may have accidentally omitted an attachment or something - I don’t see the commands you tried, or the error messages you recieved. Please provide more detail, thanks.

You will probably have the best luck installing via Conda if that is possible - if your network problems can be sorted out.

– Charles


Sorry, I forgot to upload my environment. Figure 1 shows my current environment. Figure 2 shows the code after running the. tar file. I may have to use the. tar file due to the network environment. Thank you very much for your help.

If you are installing from pip there is no Conda environment. It seems that you have mixed the two installation methods.

If you install with pip the mfix binary winds up in $HOME/.local/bin, if that is in your $PATH simply type mfix to launch it.