[18.1] Installation Instructions for MFiX 18.1

Please read the 18.1 Installation instructions for details about installing MFiX.

To install MFiX, go to https://mfix.netl.doe.gov/mfix/download-mfix/ (registration required)

More detailed instructions are available in the MFiX User Manual

Note: To open links in a new tab, go to preferences (click on your name on the upper right corner, then click on the gear icon), go to “Interface”, check “Open all external links in a new tab”, and click “Save changes”


Is there an Anaconda package in the “*.tar.bz2” format that we can download and install offline? I managed to build dependencies behind company firewall and proxy settings but when I try to install mfix using “conda install mfix -c https://…”

Could you help me with this please?

Please do not post any image showing your token. Have you tried https://mfix.netl.doe.gov/doc/mfix/18.1.5/user_manual/reference/faq.html#how-do-i-install-mfix-to-a-system-not-connected-to-the-internet-offline-install ?

I have tried to install the MFiX18.1 in windows and followed the steps described in https://mfix.netl.doe.gov/mfix/download-mfix/ . I am facing the following error could you please help me.

(mfix-18.1) C:\Users\SYAM>conda install mfix -c https://usr.:key@mfix.netl.doe.gov/conda/dist
Collecting package metadata: failed

CondaHTTPError: HTTP 401 UNAUTHORIZED for url https://usr.:key@mfix.netl.doe.gov/conda/dist/noarch/repodata.json
Elapsed: 00:01.344961

The credentials you have provided for this URL are invalid.

You will need to modify your conda configuration to proceed.
Use conda config --show to view your configuration’s current state.
Further configuration help can be found at https://conda.io/docs/config.html.

Please don’t post your usr name and key!

I think we are still having some server issues after moving the sites.

Sorry about that and thank you for editing the user name and key. What should I do now?.

I know other users had issues as well. Are tou outside the US?

I am from Brazil.
I am having the same problem. I’ve tried in both Linux and Windows and I’m getting the same message. I checked Anaconda and it is able to install other packages in mfix env. Even trying some github suggestions whenever a similar error appeared when installing a third party software I couldn’t make the installation.

Yes. I am outside the US and I am from India.

Dear MFix-Team,
I am having the same problem: I am able to install Anaconda and activate the environment but the installation of MFix fails with the same error given by Syam_S.
PS: I am from germany.

Thanks for the feedback. I suspect that something is not configured correctly on the new server. Let me pass this information to our web team.

Please try again, I believe the token issue has been fixed.

The issue persists and showing the same error.

Did you get a new token from the website?

Now it is working and successfully installed MFiX . Thank you for your support.

Awesome! Thanks for being patient during this transition.

Just an hour ago, it was working, but it is broken again. And when it was working, it installed only the version 18.1.3. Shouldn’t it be 18.1.5?

I was also able to install the MFix Version 18.1.5, thank you for the support!