3D Cylinder in Cross-Flow, Single-Phase Flow: Error, cells adjacent to cyclic boundaries not the same size

I am trying to simulate a 3D circular cylinder in cross flow; I am adapting this simulation from the tutorial on 2D cylinder flow for vortex shedding. I thought it would be a straightforward process, but after 3D-ifying the simulation, I get the errors:
“Error 1100: Cells adjacent to cyclic boundaries must be of same size:
DY(JMIN1) = 0.35941
DY(JMAX1) = 0.35941”

“Error 1100: Cells adjacent to cyclic boundaries must be of same size:
DZ(KMIN1) = 0.10000
DZ(KMAX1) = 0.50000E-01”

Confusingly, it reports the cell sizes as the same in the first case! It seems like an issue with my geometry and mesh. I have tried adjusting the control points for the mesh as well as the domain sizes, but no success.

Another issue is when selecting the cylinder as a no-slip wall for the boundary condition, I get this error:
“There are no facets selected with region Cylinder. Please make sure this is a valid region on the region pane.”

I would appreciate any help or ideas with these issues, thank you! Here are the simulation files:
2022_06_21_vortex_shedding_fld_2d.zip (2.4 MB)

The test on grid spacing is too strict, DY(JMIN1) and DY(JMAX1) are almost the same, up to the 15th decimal. When I ran the case you sent, it didn’t complain about DZ.

We will need to relax the test for the next release. In the meantime, edit check_geometry.f, go around line 67, and comment out the CALL LOG_ERROR() as shown below:

         IF(DY(JMIN1) /= DY(JMAX1)) THEN
            WRITE(ERR_MSG,1100) 'DY(JMIN1)',DY(JMIN1),'DY(JMAX1)',DY(JMAX1)
            !CALL LOG_ERROR()

and build the solver again.

Since you are using quadrics, you also need to set

bc_id_q(1) = 15

in the mfx file. Go to the Modeler>Advanced pane to set this keyword.

1 Like

Hi Jeff, thanks for your detailed response. I followed your steps and the simulation made it farther, but ran into a new error in the first iteration:

Error from cartesian_grid/get_delh.f:68
MFiX will exit now.

Are you able to offer any thoughts on this error, @jeff.dietiker? I have attached the case file and included the .LOG file from the attempted run. I wonder if this error is due to some flaw in my process of transforming the 2D cylinder flow into a 3D case. I’m going to try creating another simulation, from scratch.

2022_06_21_vortex_shedding_fld_2d.zip (2.5 MB) (Slightly updated file to enable UDFs for check_geometry.f)

Edit: I tried enabling array re-indexing under Mesh>Mesher, but still no success.

I am not sure, it is running fine for me (Linux).