After the reaction is initiated, no products are generated

Hello researcher, I am very curious about something. A week ago, I ran a calculation example that successfully ran and produced products. However, when I ran this example again today, there was no product generation, and no matter how I debugged or modified the parameters, it had no effect. I don’t know where the problem is. Can you help me check it out? Thank you very much. (4.2 MB)

Please explain exactly what is the difference between the successful and unsuccessful simulation. This will increase the chances of getting a useful reply.

Simply put, I simulate the same example at different times and the results are different. Previously, there were products generated in the simulation results, but now, there are no products generated in the simulation results.

Same version of MFiX?

Different versions are used. It is interesting that after the version update, the results of the same calculation example before are different, so I also want to know the reasons for it. Therefore, I earnestly request that the researchers help me take a look at my calculation example. Thank you very much.

Please copy/paste the following in your .mfx file (in a text edit outside the GUI):


and let us know if this helps. These keywords will be exposed in the GUI in 23.4 release.

The latest version 23.3.2 has larger default values


and I am suspecting you need to decrease STIFF_CHEM_MIN_RATE and/or STIFF_CHEM_MIN_SPECIES

Hello, and thank you for your reply. I set it up according to your method, and there are three questions:

  1. There is still no product produced. Is there any other solution?

  2. How did you know that the problem was caused by a chemically rigid reactor? Did you find the solution through experience or through GDB debugging?

  3. I want to debug error cases from the underlying code. How can I operate on Linux? Or what command lines should I use?

Thank you again, and I sincerely hope to receive your detailed response.

  1. I don’t have sufficient information to provide a solution.
  2. I was only guessing based on the limited information I have. I know the tolerances changed so it could have been the source of your issue.
  3. First, make sure you are actually running the same simulation (input file and udfs). Then document the different results. Do a hand calculation of the reaction rate values you are expecting and compare with what you get. The simplest way to debug is to add print statements in the code.

Thank you for your patient reply. I will try again.