Convergence difficulty of a fluidized bed using TFM, DT<DT_MIN divergence

Hello everyone!
I am using mfix-21.1.4 to calculate the fluidized bed under Linux system. Now the calculation has reached three quarters, but appears dt<dt_ Min, what is the reason for the divergence?
In addition, when the inlet gas phase velocity is 0.38 m/s, the calculation is completed successfully. When the velocity is increased or decreased, the calculation will diverge. The lower the speed, the faster the divergence.
I checked the mfix guide and mfix forum and found some solutions.I have tried to include but not limited to the following measures:
(1) Modify the time step; (2) Increase the number of iteration steps; (3) Change the discrete method; (4) Using ideal gas law for the gas density; (5) Change the packed bed void fraction; (6)Reduce underrelaxation factors;(7)Encrypt grid.
However these measures did not solve my problem.
Can anyone help me? I would be very grateful. Here are the relevant documents. (Examples of decreasing velocity and increasing velocity respectively, only changing the velocity)
Taghipour3D_0.1_schaeffer.mfx (8 KB)

Taghipour3D_0.46_schaeffer.mfx (13.3 KB)

What is driving the time step to drop (lack of convergence for a given residual, unphysical results)?

Hi Jeff, thanks for your reply.
The following is the bug report, I hope it will be helpful for you to understand my problem, I really need to solve this problem urgently, looking forward to your reply.
Best wishes. (7.0 MB)

Should not be anything major, it ran fine for 5 days. Have you tried to do a restart? This can sometimes let you go over a numerical instability.

If you have more than one core, you should consider running in dmp mode.

A few things you could try:

  1. Use the latest 22.1 release.
  2. change the inlet bc granular temperature.
  3. Set the outlet void fraction to 1 and outlet solids fraction to 0.

Thank you, Jeff. I will try what you give me. But I’m sorry to bother you with another question. As I said before, the lower the setting velocity, the faster the divergence. The following is a bug report with a velocity of 0.03m/s. I want to know why it can’t run. I’m sorry to bother you again. I look forward to your reply. (34.2 KB)

I am not sure, I cannot reproduce the divergence. The case with inlet velocity of 0.1m/s ran to completion (25 seconds) and the case with inlet velocity of 0.03 m/s has not failed yet.

Thank you Jeff. I will try again.