Default solver not available for MFIX-GUI-20.1.2

Dear mfix developers,
I am using MFIX-GUI -20.1.2 . After setting up my model and attempting to run it, the default solver or any solver for that matter is not available for selection. This is not the case with the previous 19.3.1 version. I have attached my file herewith for your attention. sscp1.mfx (11.9 KB)

1 Like

Please go to Menu –> About and press the icon next to “Copy the following information when reporting issues to the support forum" and paste the info here.

1 Like

Sure and thank you for the reminder.

Was this ever resolved? I still do not have a solver available.

MFiX version: 20.1.2
Python version: 3.7.6 (default, Jan 8 2020, 13:42:34) [Clang 4.0.1 (tags/RELEASE_401/final)]
Qt Wrapper: PyQt5
Qt Version: 5.12.8
qtpy Version: 1.9.0
Numpy Version: 1.18.1
Nodeworks Version: Unavailable
Flask Version: 1.1.1
Sphinx Version: 2.4.0
psutil Version: 5.6.7
VTK Version: 8.1.2
OpenGL Backend: 2
System info: Darwin release 19.4.0 running on x86_64
Install location: /opt/anaconda3/lib/python3.7/site-packages
Default Solver executable:None
Solver source code: /opt/anaconda3/lib/python3.7/site-packages

We no longer provide a default solver for Mac, due to limited developer resources. However, building a custom solver only takes a few minutes. See the section on Custom Solvers in the User Manual; let us know if you have difficulties building the solver on Mac.

Hi Mark, I installed homebrew and then did: Run brew install gcc boost open-mpi. After this, I went to build the solver, and I am getting this message:

Also run brew install cmake. Yeah, the documentation ought to mention that; I’ll add CMake to that list.

Hi Mark, thanks for all your help so far. I was able to install cmake, but of course I receive another error.

You can try running build_mfixsolver from the directory your .mfx file is in.

You could also try installing the MFiX 20.1.2 Source tarball with Pip, to see if you have better luck with that.

Hi all,

I am using mfix-21.4 and started doing the first tutorial. The default solver was not available for selection, and therefore I followed the thread suggestions and installed dependencies (brew install gcc cmake open-mpi). However, still I get an error.

output:

clang: error: unknown argument: '-ffpe-summary=none'
make[2]: *** [CMakeFiles/mfixsolver_ext.dir/f2pywrappers/mfixsolvermodule.c.o] Error 1
make[2]: *** Waiting for unfinished jobs....
clang: error: unknown argument: '-ffpe-summary=none'
make[2]: *** [CMakeFiles/mfixsolver_ext.dir/Users/xxxx/opt/anaconda3/envs/mfix-21.4/lib/python3.8/site-packages/numpy/f2py/src/fortranobject.c.o] Error 1
[ 98%] Building Fortran object CMakeFiles/mfixsolver_ext.dir/pymfix/exit.f90.o
make[1]: *** [CMakeFiles/mfixsolver_ext.dir/all] Error 2

Ok, it looks like this is a compiler option that is not supported on the MacOS platform.

Edit the file model/CMakeLists.txt in the text editor of your choice, and simply delete lines 589-590:

589  # don't spew irrelevant warnings at exit
590  target_compile_options(mfixcore PUBLIC $<$<STREQUAL:${CMAKE_Fortran_COMPILER_ID},GNU>:-ffpe-summary=none>)

You may also have to delete the line aboce that which sets --fpe-trap if you get warnings about that.

Let us know if this works,

– Charles

I’m a little confused why the error refers to clang while the compiler is set to gfortran.

Hi Charles,

Thanks - this worked! I deleted --ffpe-trap as well.

Nilanka