HTTP 401 error during installation MFIX-22.3

Dear developers,
Hope you are doing good!
I met CondaHTTPError: HTTP 401 UNAUTHORIZED error when installing MFIX22.3.
I found that the same problem apeared in this topic Installation problem for MFIX 19.1 - MFiX / Installation - NETL Flow Science Software Support (
Is it an error with the script on the server updating download permissions as well with recently released version or another problem? Could you please help me to solve this?
I have tryed to install it on two different computers Win10, 64bit. The same error.

If you are a registered user, you should not be seeing this 401 error. There are a few possible reasons:

  1. The download tokens expire after 24 hours, to prevent link-sharing. You may need to get a fresh download link.

  2. There is a limit of 5 distinct IP addresses per month, for the same reason. If you have tried from a lot of different systems you may have to wait before retrying.

Sorry for the inconvenience and please let us know how it goes!

Yes, problem was in expired link. Updated and installed.
Thank you for your explanation and help!