Mesh generation of cylinder

Hi, everyone,

The following is a mesh image of a cylinder. The mesh is generated by uniform division of the region outside the cylinder. I find that there are several hollows on the surface of the mesh, as circled by blue lines. The question is, now that the region is divided uniformly, how are these hollows generated?

In my PIC simulation, the problem “velocity higher than maximum allowed velocity” occurs. I guess it may be caused by theses hollows. So, how can i remove these hollows? I adjusted several parameter, such as TOL_SMALL_CELL and TOL_SMALL_AREA, but they didn’t work. Could you please tell me how to solve this problem?

Thank you!

When changing the cells numbers, some swellings appear on the surface. The source file is attached here. I really hope someone can tell me how to improve mesh quality.

source_file.zip (11.9 KB)

Try reduce the dot product tolerance to 1E-4.

Hi, Dr. Dietiker

Recently, i found that the “implicit” method is better than the “primitive” method to create geometry like cylinder, for which relevant parameters of mesh generation, such as the dot product tolerance, are not necessary to adjust to make a smooth mesh surface. In addition, according to your advice, the mesh surface of the cylinder generated by using the “primitive” method was smoother than before, but the simulation was also not running successfully. On the contrary, when i employed the geometry generated by using the “implicit” method without adjusting any parameters to generate mesh, the case of the same setting ran successfully.
What is the difference between these two geometry generation methods? Why the “implicit” method seems better to create high quality mesh? Thank you.

I think these are due to the quality of the stl files (i.e. triangles). Primitives and Implicits are handled through the vtk library so we don’t have much control over it.