MFIX does not response

Four days ago, I updated MFIX from version 21.2 to 21.3, but when I opened the software, there was no response. Uninstalling Anaconda3 for reinstallation, reinstalling MFIX21.2, and even reinstalling the computer system did not solve the problem.
After that, I switched to a different computer and reinstalled Anaconda3 and MFIX, which worked without any unresponsiveness. I guess it’s Anaconda3, but I don’t know how to fix it.
Here is some information about the software.

MFiX version: 21.2
Python version: 3.8.12 | packaged by conda-forge | (default, Oct 12 2021, 21:22:46) [MSC v.1916 64 bit (AMD64)]
Qt Wrapper: PyQt5
Qt Version: 5.12.9
qtpy Version: 1.11.2
Numpy Version: 1.19.5
Nodeworks Version: Unavailable
Flask Version: 2.0.2
Sphinx Version: Unavailable
psutil Version: 5.8.0
VTK Version: 9.0.3
OpenGL Backend: 2
System info: Windows release 10 running on AMD64
Install location: D:\Anaconda3\envs\mfix-21.2\share\mfix
Default Solver executable:D:\Anaconda3\envs\mfix-21.2\Scripts\mfixsolver.exe
Solver source code: D:\Anaconda3\envs\mfix-21.2\share\mfix\src

Sorry you’re having so much trouble, Raymond.

Did you try running mfix -c
to clear all saved settings?

If that doesn’t work can you submit a bug report? Thanks.

– Charles

It looks like you got the mfix-21.2 and 21.3 enviroments mixed together.


C:\>  conda deactivate
C:\>  conda env remove -n mfix-21.2
C:\>  conda env list
C:\>  conda env remove -n {any other old mfix versions}

then try reinstalling 21.3. Hope this helps,

– Charles

Because the software did not respond after the update to version 21.3, so I reinstalled version 21.2, which also did not respond. The above picture is version 21.2. The current problem is both 21.2 and 21.3 have any response. I have to use 21.1.4 now.
Some details about the “no response”. After starting the software, when you move the mouse and click on any button, such as “Mesh”, the mouse will be loaded and Python’s memory consumption will increase until the software crashes.

In addition, I tried according to your suggestion, but the problem was not solved.

Are you loading a simulation file upon launching the GUI? If so please attach it here so we can try to reproduce.

What if you just load the GUI with

mfix -n

This will launch the GUI, but not try to load any previous file. If that work, go to “New Project”, select the “blank” project and let us know what happens then.

You can show resource monitors by checking the show resource monitors box in the settings pane.

Then in the bottom right corner you will see CPU and RAM usage:


If you can do that, let us know how much CPU and RAM MFiX is using on you computer.

I just load the GUI with “mfix-21.3”,when I go to the“New Project”,the GUI turns to “no response”.

Hi Charles,
I don’t know how to run mfix -c to clear saved settings , can you tell me the specific process?
Thank you!

Open an Anaconda prompt, do conda activate mfix-21.2 to set up the environment (or whatever version you are running), then enter the command
mfix -c

Thank you very much!

You can also reset the settings from the main MFiX (file) menu, this does the same thing as mfix -c . But sometimes when the GUI won’t start at all, mfix -c is easier.

Thank you very much!

After some trial and error, the problem has been solved. When loading the GUI, if Python turns to “no response”, try running the Anaconda Prompt “as an administrator”. Then reload the GUI.

It sounds like you are possibly accessing directories where you do not have permission to write or create files. What directory/folder are you using to create new projects in?