Particle Seeding in MFiX

I am simulating a fluidised bed using DEM. For a volume fraction input value of 0.6, No:of particles to seed is coming out to be 33689.

I have turned on automatic particle generation because I don’t have a particle_input.dat file.

But, after running simulation, it is showing unsuccessful seeding in .LOG file
It is using total number of particles in the system = 11640
i.e, It is using volume fraction = 0.207 instead of 0.6

Here is the screenshot explaining this problem:

How can I fix this issue?
I am new to forum. If you need any additional information to help me, please let me know.

It is unlikely you can seed particles at a volume fraction of 0.6. There is always a gap between particles and the wall (to avoid overlap), and also a default spacing of 0.05diameter.

First, do you really need to be packed initially?

If so, I would suggest running a first simulation where you use a larger (usually it means taller) vessel so you can fit all particles, and let then settle under gravity. Then you can use this as your initial condition for the actual production run.

If you don’t need to be initially packed and you have enough room, make the initial condition region larger and specify either the number of particle or inventory. These are usually a better input for DEM.

You can get a slightly denser bed if you set the spacing to zero (keep the hexagonal lattice), by showing the DEM seeding options in the Initial condition pane:

Thank you sir for taking out time to help me.

You meant - Initially fill the entire column with 34395 particles, and let them settle under gravity. It means, there is no gas inflow, so it is a granular flow. Right?

In the region consisting of entire column, I created an IC putting particle count = 34395. I turned on disable fluid solver (pure granular flow) and ran the simulation.

The following error is occuring:

I can’t tell the number of particles, you would need to do a hand calculation based on the inventory you need. If you go with the first option (do a run to settle particles under gravity), then yes the idea is to run a pure granular flow because it is faster. I am not sure about the error you get. Please attach the case files if you can so someone can take a look.

Sure sir, Here I am attaching a zipped folder consisting of .mfx file of settling particles under gravity.

Please let me know if anything else is required from my side.

Thank you.
LLDPE_Settling_particles.zip (6.8 MB)

We typically use a “Background” region that initializes the entire field with a void fraction of one. Then other IC regions are superimposed on top of this Background region.

Here you deleted the beackround region and by specifying the number of particles, it makes the void fraction undefined, which triggers the error message.

Create a region (you can call it “Background” for example) that covers the entire domain, and use it to initialize the flow field with a solids fraction of zero. then move it up (use the up arrow on top of the region table in the IC pane) so it becomes the first one. The second region will be “Column” with 34,395 particles.

Thank you sir.

I made the particles settle under gravity, stored the particle locations in particle_output.dat file. I renamed it as particle_input.dat file and used it in the actual run. This solved my problem.