Reaction happens only in a certain region

Hi developers,
I revised the demo silane pyrolysis and let it happen in a conical spouted bed.
Everything goes well except that I found that RX4 reaction only happens in the initial boundary condition “bed region” while RX3 (another heterogeneous reaction) works well. I checked the reaction kinetics and did not find a clue. Attachment is my cases. Looking forward to your reply. (6.4 MB)
Best regards

Hi @yueyuanhe
I suggest you use Monitors to get a better look at what’s going on.
mfix.dat (21.1 KB)

Here’s a modified version of your file where I created 3 monitors, one for the bed region, one for the region below the bed (ymin-ymax/4) and one for the region above the bed (ymax/2-ymax).

In each region, I monitor the MAXIMUM of the mass fractions for SiH4 (X_g(1)) and Si_H2 (X_g(2)) as well as the rates for reactions R3 and R4.

I ran up to a simulation time of about 1.77s (disk filled up before I got to tstop=2.0s) Here’s the results:

BED.csv (15.8 KB)

BELOW_BED.csv (15.8 KB)

ABOVE_BED.csv (15.8 KB)

In all 3 parts of the model, you will see that reaction R3 proceeds but reaction R4 has rate 0 everywhere. This is probably because there is no SiH2 anywhere, which is the reactant for R4…

Hope this helps,

– Charles

1 Like

I tried your methods but my results shows that RX4 indeed happens in the initial bed region,but not at the central part. If you check the contour of the fluid phase data, you could find it.

I also check the SIH4 distirbution,i fills the whole inside of the rector.

So, it is quite wired. I have changed the bed region size and waiting for the results.
Kind regards

What is the simulation time corresponding to those images?

My guess is you are below the threshold below which we stop tracking species:

There is also a threshold for reaction rates:

You can adjust these settings, but it may become more difficult to converge.