Reducing particle number in a fluidized bed

Hi, MFIX funs,
I was simulating a fluidized bed with DEM solver. But I found the particle number keeps reducing. I have increased the reactor height to a quite high level but it does not work at all. It is wired who is eating my particles. Attachment is my case. Thank you. (4.3 MB)

I found it was caused by STL file. If I replace it with MFIX own geometry tools,it was fixed. However, the simulation efficiency is very slow

Moreover, when I run it with mpi, it fails with Dt<DTmin even if i have increased it to 1*10^-6. I am wondering whether it is because the inner STL file can not be divided. (7.2 KB)

I ran with the 24.1.1 release. I didn’t get the DTMIN error. You can speed it up by setting the fluid normalization to 0 (Numerics>Residuals pane)

1 Like

Hi,jeff, did you run it with mpi? it works well with single core.

Yes I ran with 128 cores.

Could you post the case? I am wondering how you divide the domain and whether the STL missing facet will eat the particle.

It is the same case you sent. I used a NODESI=4, NODESJ=32, NODESK=1 partition. I was looking at the convergence issue. There are a few particles that leave the domain (particle count goes from 16,114 initially to 16,108 after 0.65 seconds of simulation). I did not investigate that.

I see a few particles going through the STL walls. My guess is the particle and/or walls are too soft. Please try to increase the spring stiffness to see if it helps.