Solver build fails on Windows 10 without any messages

Hello researchers. I am very curious now: does the MFix-23.3 version support installation on Windows systems? I have repeated this situation six times, and I am not sure what to do. Can you provide some suggestions?

Additionally, during the installation process, there are always errors in the following image, and I don’t know why.

Thank you all.

Yes, MFiX 23.3 has been tested on Windows and should install without issues. You should not have to repeat the installation.

The “retrying with next repodata source” message can be ignored.
It’s not clear why the build is failing with no output. Can you please do the following:

  1. Select the “Verbose build output” checkbox and repeat the build. The copy/paste all the text in the build output window (this is better than a screenshot since sometimes the screenshot doesn’t show the full text).

  2. Go to main menu, click “Submit bug report” and upload the resulting ZIP file.

Hello researcher, I have copied the error content as follows:
Running python -m mfixgui.build_mfixsolver -j -DCMAKE_Fortran_COMPILER=gfortran --verbose
Building custom solver for silane_pyrolysis_tfm_2d.mfx
Running cmake command:
cmake -DCMAKE_Fortran_COMPILER=gfortran -DENABLE_PYMFIX=ON -G “MinGW Makefiles” -DCMAKE_INSTALL_PREFIX=F:\Mfix_example\silane_pyrolysis_tfm_2d -DUDF_DIR=F:\Mfix_example\silane_pyrolysis_tfm_2d F:\Users\PC\anaconda3\envs\mfix-23.3\share\mfix\src



Additionally, an error report has been provided. Could you please help me check where the problem lies? Privately, I also know someone who is using MFix, and they have the same problem on Windows systems. (72.5 KB)

I am testing this with MFiX 23.3 on Windows 11 and it works fine. I will try to get my hands on a Windows 10 machine for testing.

There’s really no other output? This is odd. I see you enabled “verbose”. Without any error messages, this is difficult to debug. How about if you try this command at the Anaconda prompt, in your project directory:

(mfix-23.3)>  build_mfixsolver --verbose

or even copy/paste that whole cmake command line:

(mfix-23.3)> cmake -DCMAKE_Fortran_COMPILER=gfortran -DENABLE_PYMFIX=ON -G “MinGW Makefiles” -DCMAKE_INSTALL_PREFIX=F:\Mfix_example\silane_pyrolysis_tfm_2d -DUDF_DIR=F:\Mfix_example\silane_pyrolysis_tfm_2d F:\Users\PC\anaconda3\envs\mfix-23.3\share\mfix\src

Does cmake work at all? How about gfortran?

(mfix-23.3)> cmake --version
(mfix-23.3)> gfortran --version

Thanks for your patience, we’ll get to the bottom of this!

Hello, I tried your method and still made the same mistake. I always encounter this error during the installation process; I don’t know why. Is it due to gfortran or cmake?

Again, “Retrying with next repodata source” is not an error. You can safely ignore this message.

Note that after the message about current_repodata.json. it retries and succeeds - the environment is successfully solved and packages are downloaded. This is a normal, successful installation. If you want to know more about the current_repodata message and why it appears, please read this section of the Conda documentation, although understanding Conda at this level is not necessary to install and use MFiX.

This problem also has nothing to do with the failure to build the solver. Installation and solver compilation are two completely separate processes. Let’s concentrate on the solver build failure.

Now, what output do you get when you run these commands?

(mfix-23.3)> cmake --version
(mfix-23.3)> gfortran --version
(mfix-23.3)> build_mfixsolver --verbose

Please run these commands and paste output here.

Thank you.

– Charles

Regarding the installation warnings: You may also be interested in using Mamba to install MFiX - this runs much faster than conda, and produces fewer warning messages.

Ok. I have entered the command three times. Strangely, the first command did not respond; was the second command correct? The third command displays an error message.

Thank you for your reply. How do I install MFIX using Mamba?
Best wishes!

Additionally, I input commands on the control end and found that cmake has been successfully installed. However, entering the command in (mfix 23.3.1) did not result in any response, and I don’t know why.

Here’s the link for the Mamba install: - we will probably switch over to this as the “official” installation at some point.

I have never seen this issue where cmake --version produces no output. This is quite unusual, I will look for a solution, but I cannot reproduce this.

Does gfortran --version produce any output?

Hello, staff. When creating with the cmake --version command, there was no response, as shown in the following figure.

When creating with the gfortran --version command, there was a response, as shown in the following figure.

This is very strange! I am trying to find an answer, but this is really not an issue with MFiX at all but with the Conda system. I’ll let you know what I find.

Thank you very much for your reply. I will always wait. But due to the time difference, I may not be able to reply to you in a timely manner. I’m very sorry.

No worries, we have users all around the world in different time zones, and nobody expects immediate replies (or at least, they shouldn’t!). Also note I will be on vacation all next week, so you won’t hear from me for a little while.

Copy that. I wish you a pleasant holiday. I am looking forward to your reply to this question. Thank you.

I suppose one thing you could try is forcing a different CMake version:

# Show currently installed verion
(mfix-23.3.1)C:> conda list cmake  
# packages in environment at C:\Users\cgw\mambaforge\envs\mfix-23.3.1:
# Name                    Version                   Build  Channel
cmake                     3.27.6               hf0feee3_0    conda-forge

# Shows all available versions
(mfix-23.3.1)C:> conda search -c conda-forge cmake 
# Name                       Version           Build  Channel
cmake                          3.5.0               0  conda-forge
cmake                         3.27.5      hf0feee3_0  conda-forge
cmake                         3.27.6      hf0feee3_0  conda-forge

MFiX requires CMake version at least 3.16 (or maybe 3.24?) but you could try installing some different CMake versions and see if it helps:

(mfix-23.3.1)C:>  conda install -c conda-forge cmake=3.27.5

Keep trying different versions, working backward until you find one that works (produces output when you run cmake --version).
If this works for you please let us know!

– Charles

Thank you for your patient reply. I will give it a try and keep the installation process updated.

Please see

It looks like there may be a problem with the cmake 3.27.4 in conda-forge (the library MSVCP140D is a debug library, production code should not depend on this, so perhaps this package was improperly built using debug mode). Version 3.27.6 is reported to work. So conda install -c conda-forge cmake=3.27.6 should fix the issue for you.