Unable to create RES file

Hello researcher, I am currently using the gdb method to debug the code. It is possible that I accidentally deleted some files, resulting in my inability to create the RES file, as shown in the following figure.

Additionally, when I input the debugging command, there is no stack generation, as shown in the following figure.

Can you please provide some solutions?
1129.zip (15.1 KB)

I have not tried your attached files, but the error you see is likely due to either

  1. You did not delete the .RES file from a previous run
  2. You built the serial solver but you are running in DMP mode.

I think there is no stack because MFiX exited cleanly after the detecting the error (this is not a crash, the data checks detects an error and terminates)

Hello, thank you for your reply. Is there any solution to the situation where there is no stack?

I am not sure you will get a stack with this particular error. Have you tried my suggestions above?

Thank you for your reply. I will try again later. I thought I accidentally deleted some files, so I uninstalled MFIX. Currently reinstalling, error keeps occurring: HTT000. Is this a problem with my network or with the download node in my country?

The problem is not that you deleted files but that you did NOT delete files!

MFiX is trying to protect you from clobbering the RES file. If the RUN_TYPE is NEW (not a restart), and a .RES file exists, then MFiX will refuse to start, with the error message above (perhaps the message could be clearer). So you need to clear outputs from previous run before starting a new one.

Note that when you are running from the GUI, a popup is presented which gives you the option to delete outputs from a previous run. And the interactive mode solver supports a flag -c (clear) which will clear all outputs from a previous run before starting. But this is not supported with the batch solver, so you will have to delete the outputs yourself. There will be others too … .vtk files, etc.

As Jeff said, there is no stack after the program exits normally. You will only get a stack trace on some kind of unexpected error.

Also note, it is possible to use gdb with the interactive (Python) solver but it’s tricker … you debug python itself and then at the (gdb) prompt do:

run -m mfix_solver.pymfix -d . -c -f myfile.mfx

The -c flag will clear the output files before starting the run.

– Charles

Thank you for your very patient answer. I will try it again after the MFIX is installed.