Want to use last VTP file as input for next simulation

I have made a conical pile of particles using mfix now i want to use that last result as input for another simulation . how do i do that?

You can save the particle info into a particle_output.dat file by checking “Save particles positions at end of run” in the Output pane. You can also set the velocity to zero if you want to (see below).

Then you can examine the file to make sure it is OK and rename it to particle_input.dat. To use this file as a starting point instead of the automatic Initial Condition, go to the solids>DEM (or Solids>CGP if you use CGP) and uncheck “Enable automatic particle generation”:

Dear sir, it is not working.

I have created a stockpile using DEM now i want to provide velocity on one side to see how particles flow from that stockpile. Can you kindly help regarding this issue ?

  1. Can you please provide more details about what is not working?
  2. If you want someone to take a look, please upload your project files. Th easiest way to do this is to create a zip file from main menu> submit bug report and upload this zip file to the post.

Dear Sir,

The topic of my work is " Dust emissions from stockpile".

  1. For that, the first part is I have to create a stockpile with DEM as seen in the picture attached herewith

  2. Once this pile is created, I want to apply velocity from x direction to see the effect of wind on this stockpile and how these particles will be eroded from pile.

For this issue, I need the last file in which the stockpile is formed to run as an input file for the second part of the simulation where I will provide velocity to check the movement of particles after the formation of the pile.

Kindly find the attached compressed folder for all files
hopper_dem_3d_2022-11-18T131419.070145.zip (19.0 MB)

Kindly help me how to resolve this issue

A few suggestions:

  1. For the first run, do not use a flat bottom for the hopper. Otherwise you will have particles that will stay in the hopper.
  2. For the first run, disable the fluid solver so it runs faster.
  3. At the end of the first run, rename particle_output.dat to particle_input.dat
  4. For the second run, remove the stl file and use a smaller domain in the vertical direction. Use a Mass inlet BC on the side.
  5. Is this the actual particle size (5cm) or just a test case? You will need a pretty high velocity to move them around.

Sir I have followed the instructions:

  1. I have changed the hopper and disabled the fluid solver as seen in the picture attached.

  2. Then I did rename particle_output.dat to particle_input.dat and removed stl file, using a smaller domain and mass inlet BC. But after the run, I cannot see any particles.

particle_input.dat (2.0 MB)

  1. This is test run particles can be of smaller size in the range of 2.5 mm

Kindly let me know how to deal with this issue.

Did you uncheck “Enable automatic particle generation” in the Solids > DEM pane?

https://mfix.netl.doe.gov/doc/mfix/22.3/html/faq.html#how-to-provide-initial-particle-positions-in-particle-input-dat-file

Yea sir I did that, But i could not see any particles after that.

I think there is a bug. Please set the Data file particle count to 1 to bypass the bug. The actual number of particles will be read from particle_input.dat

image

I want to study the effect of wind velocity on piles of bulk and dust particles. so first I drop both materials using a hopper system for the first simulation and then once the entire material drops I want to give velocity from one end to see the behavior of particles.


particle_input.dat (600.5 KB)

I am using the last data file as input for the second simulation to give velocity at one side of box . simulation it is reading particles but it is constantly showing an Error from time_step.f:196
DT < DT_MIN. Recovery is not possible! kindly help.

Please attach all setup files.

hopper_dem_3d_0809.zip (33.5 MB)
kindly find the attached files

The files you attached don’t seem to match the image above. There is no STL file and you used an implicit box as the geometry, which is unnecessary. The regions extents are also incompatible with the MFiX box so I cannot even do the meshing. Please double check you files.