why:Error 1000: Required input not specified: SPECIES_g(1)?

The mfix can’t run correctly with the pure granular flow and enable energy euation on.
and the error comes up:Required input not specified: SPECIES_g(1)??? I don’t have gas in the model!!

123_2022-06-27T215433.403401.zip (38.9 MB)

This is a bug in MFiX, we are working on a fix and this should be resolved for 22.2

As a work around, please try the following:

  1. Go to the Model setup pane: uncheck “Disable fluid solver (pure granular flow)”. This will unlock the Fluid pane.
  2. Go to the Fluid pane. Set a constant value for the gas specific heat and the thermal conductivity. You can set the thermal conductivity to zero if you do not want to have heat transfer between gas and solids.
  3. Go to the Model setup pane: check “Disable fluid solver (pure granular flow)”

Then you should be able to run the simulation.

1 Like